読者です 読者をやめる 読者になる 読者になる

gemがインストールできない件

なんか良くわからないが、とりあえず、ずるい感じでインストール出来たので、メモ だれか詳しい人、教えてくれると、嬉しいです。 僕はrbenvをつかっていて、ruby 1.9.3p448 での環境です。

aws-sdkのgemをインストールしようとしていたんですが、下記のようにエラーメッセージが出て来て困りました。

$ gem install aws-sdk

SSL_connect returned=1 errno=0 state=SSLv3 read server certificate B: certificate verify failed (https://s3.amazonaws.com/production.s3.rubygems.org/latest_specs.4.8.gz)

下記のように.gemrcをつくってssl verifyをしないようにしたら、インストールできましたが、 ssl verifyをしていないので、不安です!

echo ':ssl_verify_mode: 0' >> ~/.gemrc

だれか、正しい解決方法をおしえて!